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1 - Creating a Custom Tool

Preparation
\ Open a new GeoGebra file.

\ Hide the algebra window and the co-
ordinate axes (View menu).

\ Change the labelling setting to “All
New Objects”
(menu Options→ Labelling).

\ You can view the file newtool.html
to see the completed product.

We will create a rectangle with given length and breadth. We will then use this file to create a
tool of our own that will allow us to create a rectangle of any length and breadth by clicking on
a point and inputting two numbers.

Step-by-step Instructions

1.
Click on the Drawing Pad to create the slider a. This will represent the length
of the rectangle. Let it vary from 0.1 to 5

2.
Click to create the slider b. This will represent the breadth of the rectangle. Let
it vary between 0.1 and 5

3.
Click in the Drawing Pad. Type a into the pop-up menu that appears to create
the line segment c and the point B

4. Click on the point B and the segment c to create the perpendicular line d

5.
Click on the point B. Type b into the pop-up menu to create the circle e with
centre B and radius b

6. Click on the circle, e, and the line, d to create the intersection points D and C

7. Click on the point D and the line d to create the line f perpendicular to d

8. Click on the point A and the line d to create the line g parallel to d
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9. Click on the lines f and g to create the point E

10.
Hide everything except the two sliders, a and b, and the four points A,B,D
and E

11. Change the Labelling settings: Options→ Labelling→ No new objects

12. Click on the points A,B,D,E and again on A

13. Apply the drag test to check if the construction is correct

You have now created a polygon which is a rectangle. It took a lot of work to do this. Math-
ematically it is a very simple object. All you need to do to draw it is know where to start, its
length and its breadth. It would be nice to have a way of just using that information and nothing
else. GeoGebra can help you do this by allowing you create a Custom Tool.

Step-by-step Instructions (continued)

14. Create a new tool from menu Tools→ Create New Tool

15.
Scroll through the list of Output Objects to select, in turn, the quadrilateral
poly1 and its enclosing segments a1, b1, d1, e1

16.
Click on the Next button. Move point A to the top of the list with the up-arrow
and highlight the Point and the two numbers

17.
Click on the Next button and in the menu name the new tool Rectangle. In the
Tool help type Select a point and 2 numbers. Click on the Finish button

18.
A message will appear that says “New tool created successfully”. Click on the
OK button and you will see that there is a new tool on the toolbar

19.
To save the tool and make it available to other GeoGebra files go to Tools→
Manage Tools

20.
Click the Save As button and name your tool. It will be saved with the exten-
sion .ggt and can be opened by any GeoGebra file
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Tasks: Use the Properties dialog to enhance the appearance of the file. Practise using your tool.
Open a new GeoGebra file and use the File→ Open menu to import your tool. If you like, and
are good at drawing icons, you can create an icon for the Rectangle tool. You can also use your
new Rectangle Tool from the Command line.

You will find many tools created by other GeoGebra users at http://www.geogebra.org/en/
wiki/index.php/GeoGebra_Tools.

2 - Sequences

Preparation

\ Open a new GeoGebra file.

\ Show the algebra window and hide
the coordinate axes. (View Menu).

\ Change the labelling setting to “New
Points Only”
(menu Options→ Labelling).

\ You can view the file seq.html to see
the completed product.

There are no new tools in this section, but there are new Commands.

The example that we will use in this section is the division of a line segment into n equal parts.
The method to use is essentially that of the Junior Certificate. In summary:

\ You are given a line segment AB to divide into n equal parts.

\ Construct any line through A.

\ Use a compass to make n equal divisions on this line.

\ Join the upper point to B.

\ Draw lines parallel to this.

\ Mark the intersection points.

A sequence of objects can be created in GeoGebra by the command

Sequence[ Object , i , Start , End ]

where Object is what you want to iterate, i is the iteration variable, Start is the starting value of
i and End is the final value of i.

For example, the following command typed into the Input field

Sequence[ ( i , i ) , i , 1 , 5 ]
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will create and plot the five points (1, 1), (2, 2), (3, 3), (4, 4) and (5, 5). These points will appear
as a list in the Algebra window. You can access any of them by giving the name of the list and
the number of the element in the list. If this were the first list created in the current session
of GeoGebra then the point (4, 4) could be accessed as Element[ list1 , 4 ] because it is the
fourth element in list1.

Step-by-step Instructions

1. Create a point A near the bottom left of your drawing pad

2. Create point B towards the top right

3. Construct the line segment a joining the points A and B

4. Create a slider called n which can vary from 2 to 6 in steps of 1

5.
In the Input Field create the vertical line b by typing
x = x(A)

6.
In the Input Field create the list, list1, of n equally spaced points on b by typing
Sequence[ A + ( 0 , i ) , i , 1 , n ]

7.
In the Input Field create the line, c, passing through the last point in list1 and
the point B by typing
Line[ Element[ list1 , n ] , B ]

8.
In the Input Field create the list, list2, of lines parallel to c by typing
Sequence[ Line[ Element[ list1 , i ] , c ] , i , 1 , n ]

9.
In the Input Field create the list, list3, of intersection points by typing
Sequence[ Intersect[ Element[ list2 , i ] , a ] , i , 1 , n − 1 ]

10. Apply the drag test to check if the construction is correct

Tasks: Enhance the colours and attributes of the objects in your file.
Can you turn the output of this file into a tool that will allow you to divide a segment in any file
into equal lengths?

3 - Checkboxes & Boolean Values
There are many times when you may want to allow the user to control exactly what is visible
in the drawing pad. The simplest way to do this is to use checkboxes. There are other more
sophisticated ways of doing this which can be accessed from the Advanced tab in the Properties
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dialog but for now we will only focus on checkboxes. A checkbox creates a Boolean value —
i.e. a variable that can take only one of two values: True or False. The Advanced tab in the
Properties dialog allows us to combine Boolean values using Boolean algebra. This also means
that more than one object (line, circle, polygon etc.) can be controlled with a checkbox. The
Boolean algebra symbols that GeoGebra uses are

\ ∧ (And), e.g. a ∧ b is True iff a is True and b is True.

\ ∨ (Or), e.g. a ∨ b is True iff either a or b or both are True.

\ ¬ (Not), e.g. ¬a is True iff a is False while ¬a is False iff a is True.

\
?
= is used to test for equality. If a ?

= b returns True then a and b are identical.

\ 6= is used to test for inequality.

Preparations

\ Open a new GeoGebra file.

\ Hide the algebra window and show
coordinate axes (View Menu).

\ Change the labelling setting to “No
New Objects”
(menu Options→ Labelling).

\ Right click in the drawing pad to bring up the Graphics View. Select the last option
Properties at the bottom of the Graphics View. Use the drop-down menu to change the
Unit to ◦. Change the xAxis : yAxis = 50 : 1

\ You can view the file checks.html to see the completed product.

Introduction of new tools

Checkbox to Show / Hide Objects New Tool!
Hint: Click on the drawing pad to create a checkbox. From the
drop-down menu select the objects for the checkbox to control

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.

Step-by-step Instructions

1.
Zoom out until you are happy that you can clearly see the number 1 on the
y-axis

2. Move the axes until you are happy with their position
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3. In the Input Field type
Function[ sin(x◦) , 0 , 90]

to get the graph, f , of sin(x) from 0◦ to 90◦

4.
Create the checkbox, a and select f from the drop-down menu. Give it the
caption sin(x)

5. In the Input Field type
Function[ cos(x◦) , 0 , 90]

to get the graph, g, of cos(x) from 0◦ to 90◦

6.
Create the checkbox, b and select g from the drop-down menu. Give it the
caption cos(x)

7. In the Input Field type
Function[ tan(x◦) , 0 , 90]

to get the graph, h, of tan(x) from 0◦ to 90◦

8.
Create the checkbox, c and select h from the drop-down menu. Give it the
caption tan(x)

9.
In Move mode check and uncheck the checkboxes to see how the functions can
be shown/hidden

Task: Use the various tools that you have learned about to enhance the appearance of your file.

Remember that you have changed the ratio of the x and y-axes so that circles etc. would look
very strange in this file! These changes are remembered if you just create a new file. It is best
to quit and re-launch GeoGebra before you do any more work.

4 - Transformation Geometry

Preparations
\ Open a new GeoGebra file.

\ Hide the algebra window and the co-
ordinate axes (View menu).

\ Change the labelling setting to “New
Points Only”
(menu Options→ Labelling).

\ You can view the file transform.html
to see the completed product.
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Introduction of new tools

Mirror Object at Point New Tool!
Hint: Click on the object and then on the point at the centre of
symmetry
Mirror Object at Line New Tool!
Hint: Click on the object and then on the line acting as the axis of
symmetry

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.

Step-by-step Instructions

1. Create a checkbox, a with the caption “Central Symmetry”

2. Use the Move tool to uncheck the box

3. Create a checkbox, b with the caption “Axial Symmetry” and uncheck it

4.
Open the Properties dialog. Highlight the Boolean Value a. Click on the Ad-
vanced tab. In the “Condition to show object” box use the drop-down menu to
enter the character ¬ followed by the letter b so that the it contains ¬b ∗

5.
Open the Properties dialog. Highlight the Boolean Value b. Click on the Ad-
vanced tab. In the “Condition to show object” box insert ¬a

6.
Create a new point, A. Open the Properties dialog. Give this point the caption
“Centre of Symmetry” and choose to display the Caption in the Label box.
Click on the Advanced tab and type a into the “Condition to show object”

7.
Click in the checkbox “Central Symmetry” to hide the “Axial Symmetry”
checkbox and reveal the point A

8. Create three new points B,C and D.

9.
Click on the points B,C,D and B again to create the triangle poly1 and the
segments enclosing it b1, c and d

10.
Click on the triangle BCD and then click on the point “Centre of Symmetry”.
This creates the image of BCD and the various points and segments surround-
ing it

∗This means that if the checkbox “Central Symmetry” is checked then the checkbox “Axial Symmetry” will
disappear. Try it out.
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11.
Open the Properties dialog. Type a into the advanced tab of the points B′, C ′

and D′, of the triangle poly1′, and of the segments b′, c′ and d′

12.
Draw the segments joining CC ′, DD′ and BB′. Open the properties dialog
and ensure they are only visible when “Central Symmetry” is checked

13. Save this file with the name ‘transform’ as we will use it in the next section

14. Apply the drag test to check if the construction is correct

Tasks: Enhance your file through the Properties dialog box.
Now use the other new tool, Mirror Object in Line, to create the image of the triangle in an axial
symmetry. Uncheck the “Central Symmetry” box and check the “Axial Symmetry” box before
you begin. Ensure you make your new objects dependent on the boolean value b instead of a
this time.

5 - Export as Web Page
We are now going to create an interactive web page. The ‘interactive’ part will be a java applet
generated by GeoGebra from the file you created in the last section. You can use this web page
on a public server, an internal server in a school, on your own computer or you can give it out to
students. It is generally a good idea to use small letters and the underscore character ( ) rather
than Capital letters and periods (.) when naming files and folders for use on the Internet. By
this I mean the actual name of the file/folder. The titles can be anything you like. The reasons
for this are because of the large number of different Operating Systems that may be looking at
your file.

Preparations

\ Create a new Directory (Folder) on
your Hard Drive. Name this folder
“webfiles”.

\ Open the GeoGebra file created pre-
viously called transform.ggb
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Exporting a Dynamic Worksheet
1. Go to File → Export → Dynamic Worksheet as Webpage (html) to bring up the window
below.

\ The Title will be the Title of your web page.
Type in ‘Transformation Geometry’.

\ You can leave the Author and Date blank, if
you like.

\ Type ‘Choose whether to view a central or ax-
ial symmetry’ into the Text above box.

\ You can leave the Text below box empty.

\ Click on the Advanced tab.

\ Right click enabled means that you can bring
up properties etc with a right click in the web-
page.

\ Enable dragging of labels will let the user
move captions or labels around.

\ You can allow the user to reset the construc-
tion and even launch GeoGebra.

\ You can choose to hide or show menus, tools
and input.

\ You can pick the width and height of the applet.

\ Finally, if you check the Java Applet box then your applet will go to the GeoGebra site to
launch

2. Click on the Export button.

3. Navigate to the Directory ‘webfiles’ that you created.

4. Accept the default name of ‘transform.html’.

5. Click the Save button.

Your default Web browser should open now and display the web page that you have created.

If you look in the Directory, webfiles, that you created you will find that there are now eight files
there! GeoGebra has created various files that it needs as well as the file transform.html and it
has also created a copy of transform.ggb. If you want to make this page available then you must
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ensure that copies of all these files are in the same directory on the server that will host your site.

If you are happy with HTML then you can open the html file with any text editor and modify it.
If you change your mind about any of the decisions you made in creating the web page the text
editor can modify the conditions for you.

6 - Challenge: Making a Geometry Page
Take any construction or theorem in the Geometry course. Use GeoGebra to demonstrate the
construction or the theorem. Use checkboxes so that the students will only be able to see what
you want them to see.

Export your final work to the Web and, if you can, use a text editor to refine your work.

Good luck!
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