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1 - Parameters of a Linear Equation

Preparation
\ Open a new GeoGebra file.

\ Show the algebra window, the input
field and the coordinate axes (View
menu).

\ Change the labelling setting to “No
New Objects”
(menu Options→ Labelling).

\ You can view the file param.html to
see the final product.

Introduction of new tools

Slope New Tool!
Hint: Click on an existing point on a line to get the slope of the line.
You can hide the slope and use its value if that is all that is required

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.

Step-by-step Instructions

1. Create a slider on the drawing pad. Call it m

2. Create another slider. Call it c

3. In the Input Field type
y = m ∗ x+ c

You must use ∗ or a space for multiplication of two letters

4. Click on the line and then on the y-axis to create the point A

5. Click to create point B at the origin

6. Create the segment AB that joins the points A and B
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7. Click on the point A to get the slope of the line y = mx+ c

8. Apply the drag test to check if the construction is correct

Tasks: Use the Properties dialog to enhance the appearance of the file. Write down instructions
for your students that guide them through examining the influence of the parameters m and c
on the line by using the sliders. You could provide these instructions on paper along with the
GeoGebra file.

2 - Adding Text

Preparation
\ Open a new GeoGebra file.

\ Show the algebra window, the input
field and the coordinate axes (View
Menu).

\ Change the labelling setting to “New
Points Only”
(menu Options→ Labelling).

\ You can view the file text.html to see
the final product.

Introduction of new tools

Add Text New Tool!
Hint: Click on the drawing pad. A menu appears. If you want
to enter text begin and end with quotation marks. If you want the
value of a variable then leave out the quotation marks. For example,
if you have a sliderm = 4 then “m” will print m on the drawing pad
whereas if you had entered m it would print the value 4
Circle with center and radius New Tool!
Hint: Click either on the drawing pad to create a new point or on an
existing point. This is the centre of the circle. A menu will appear
into which you can type the radius

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.
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The tool that you will use to construct text
is by far the most complicated tool that you
have yet encountered. You may require
text to be a literal string that appears ex-
actly as you type, something like This is a
circle. In this case you would enter the text
between quotation marks as in the picture
on the right.

On the other hand you may want the text
to be a dynamic variable. This means that
what is on the screen will change as some
value changes. For example if you have
a point, P , and you need to show the x-
coordinate of P then you would enter x(P)
in the text window. The value of x(P) that
appears on the screen will change as the
point P is dragged. It is dynamic.

The complications begin when you want to mix both of these objects in the same text block.
Within a text block a + sign outside quo-
tation marks is a symbol that instructs your
computer to join two or more strings of text
together. If you want to show a message
combining a string of text and a dynamic
variable whose value will change, for ex-
ample, This is a circle with the first coor-
dinate of its centre equal to 6, you would
enter it as:

′′This is a circle with the first coordinate of its centre equal to ′′ + x(P)

Step-by-step Instructions

1.
Create a slider on the drawing pad. Call it r and allow it to vary between 0.1
and 5

2. Create point A on the drawing pad

3.
Click on the point A to make it the centre of the circle you are constructing.
Then type r into the menu that appears and you will create a circle called c

4.
Click on the drawing pad. In the text box that appears type
′′Radius of the circle is ′′ + r
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5.
Click on the drawing pad and type the following into the text box.
′′ Equation of the circle is ′′ + c

6. ′′ x− coordinate of the centre is ′′ + x(A)

7. ′′ y− coordinate of the centre is ′′ + y(A)

8.
′′ Centre is ( ′′ + x(A) + ′′ , ′′ + y(A) + ′′ ) ′′

Do you understand why all the quotation marks are needed?

9. Apply the drag test to check if the construction is correct

Tasks: Enhance the colours and attributes of the objects in your file. Practice entering text. Try
to see exactly what the quotation marks do.
Hint: When you use the Text tool notice that there are two buttons in the dialog menu. The upper
one has the squared symbol ( 2 ) on it. This allows you to enter many different mathematical
symbols. The lower button has the Greek letter α on it. You can use this button to enter any
Greek letter.

3 - Library of Functions — Visualising the Period of sinx
As well as drawing the graphs of polynomials there are many different types of functions avail-
able in GeoGebra (e.g. the absolute value function, trigonometric functions, exponential and
logarithmic functions). Functions are treated as objects and can be combined with the geometric
constructions you may perform.
Note: At the bottom right of the GeoGebra window there is a button marked “Command...’
which contains many of the functions. There is also a list of them available at http://www.
geogebra.org/help/docuen_UK/. On the left side of the screen you will see the Contents.
Click on the item “Algebraic Input”. Then click on the item “Direct Input”, then click on “Pre-
defined Functions and Operations”. This page lists the available functions in GeoGebra.

Preparations
\ Open a new GeoGebra file.

\ Show the algebra window, input field
and coordinate axes (View Menu).

\ Change the labelling setting to “No
New Objects”
(menu Options→ Labelling).

\ You can view the file period.html to
see the completed product.
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Introduction of new tools

Segment from a point with given length New Tool!
Hint: Click on the drawing pad to create a new point or on a pre-
viously existing point. A dialog box opens in which you can enter
the length of the required segment. This length can be the name of
a slider if necessary

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.

Step-by-step Instructions

1. In the Input field type
f(x) = sin(x)

2. In the Input field type
p = 2 ∗ pi

3. Click on the graph of sinx to create the point A on the curve close to the origin

4. Click on the point A as the start point. In the dialog that appears enter p

5. Click on the segment to create its midpoint, C

6.
Click anywhere on the Drawing Pad. In the menu that appears enter the text
“Period” including the quotation marks

7.
Open the Properties dialog. Select the text — which will be called text1. Click
on the Position Tab. From the drop down menu select the point C

8.
Apply the drag test to check if the construction is correct. When you drag the
point A it should stay on the graph of sinx

Task: Use the various tools that you have learned about to enhance the appearance of your file.

The line segment is of length 2π and is the period of the curve.

4 - Graphing a Function with a Finite Domain
In GeoGebra you can limit the domain of a function to a finite interval. This makes it convenient
for demonstrating the type of function questions that are asked at Junior and Leaving Certificate
level. A question from the Junior Certificate in 2006 asked:

Regional Centre for Excellence in Mathematics Teaching and Learning Page 6



GeoGebra Workbook 3

The formula for the height, y metres, of a ball above ground level, x seconds
after it is fired vertically into the air, is given by:

y = 35x− 5x2

Use a graph to estimate

(i) the maximum height reached by the ball,

(ii) the height of the ball after 5.5 seconds.

On two occasions the ball is 20 metres above the ground

(iii) Use your graph to estimate the two times when this occurred.

We can illustrate this situation nicely in GeoGebra.

Preparations
\ Open a new GeoGebra file.

\ Show the algebra window, input field
and coordinate axes (View menu).

\ Change the labelling setting to “No
New Objects”
(menu Options→ Labelling).

\ You can view the file funcdo-
main.html to see the completed
product.

Step-by-step Instructions

1. In the Input field type the equation
Function[35x− 5x2, 0, 7]

This creates a graph of f(x) = 35x− 5x2 where x ∈ [0, 7]

2. Move the drawing pad to bring the axes down near the bottom of the window

3. Right click in the drawing pad. Change the xAxis : yAxis ratio to be 1 : 10

4. Click on the graph of f(x) to create the point A on the graph

5. In the Input field type
Segment[A, (x(A), 0)] Watch the brackets!
The command x(A) returns the x-coordinate of the point A. This will create
the perpendicular line segment a joining A to the x-axis
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6. In the Input field type
Segment[A, (0, y(A))] Watch the brackets!
The command y(A) returns the y-coordinate of the point A. This will create
the perpendicular line segment b joining A to the y-axis

7. Construct the mid-points, B and C, of segments a and b respectively

8.
Create the text ′′height = ′′ + y(A) and use the properties dialog to attach the
created text to the point B

9. Create the text ′′time = ′′ + x(A) and attach this text to the point C

10. Hide the points B and C

11. Apply the drag test to check if the construction is correct

Tasks: Enhance your file through the properties dialog box. In your completed file drag the
point A. Note the way the time and height are revealed on the screen. You can now answer the
Junior Certificate question based on your GeoGebra file.

5 - Meaning of the Derivative
Recall that the derivative of a function is the slope of the tangent to the graph of the function.
This concept, which is supposed to make things clear, can often be a source of confusion to
students. Using GeoGebra you will be able to animate this idea and change the function as
often as you think necessary.

Preparations

\ Open a new GeoGebra file.

\ Show the algebra window, input field
and coordinate axes (View menu).

\ Change the labelling setting to “New
Points Only”
(menu Options→ Labelling).

\ You can view the file derivative.html
to see the completed product.
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Introduction of new tools

Tangents New Tool!
Hint: Click on a previously created point. Then click on an exist-
ing circle, conic or function. The tangent(s) to the selected curve
through the chosen point will be drawn

Hint: Don’t forget to read the toolbar help if you don’t know how to use a tool. It might be
helpful to try out all the new tools before you start the construction.

Step-by-step Instructions

1. Use the Input field to enter the equation
f(x) = x ∧ 2
Hint: You will get the ∧ by typing Shift-6

2.
Create a slider on the drawing pad. Call it h. Allow it to vary between 0 and 4.
Set it’s value to 4 once it is created

3. Create a point A on the curve

4. Use the Input field to create point B at the following location on the curve f
B = (x(A) + 0.4 ∗ h, f(x(A) + 0.4 ∗ h))

5. Use the Input field to create point C at the following location on the curve f
C = (x(A) + h, f(x(A) + h))

6.
Create a chord passing through the points A and C. This chord will be given
the name a

7.
Create a tangent to the curve at the point B. This tangent will be given the
name b

8.
Find the slope, m of the chord a. Use the Properties dialog to hide the slope on
the drawing pad

9.
Find the slope, m1 of the tangent b. Again use the Properties dialog to hide the
slope on the drawing pad

10.
Enter the text ′′Slope of chord = ′′ + m to create a text block displaying the
slope of the chord

11.
Enter the text ′′Slope of tangent = ′′ + m1 to create a text block displaying
the slope of the tangent. You can type m1 as follows m_1 or you can just click
on m1 in the Algebra window to have it appear in your text.
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12.
In Move mode adjust the slider h down to zero and observe what happens to
the values of the slopes of the chord a and the tangent b. What happens when
h reaches zero?

Tasks: Enhance your file by changing line colours and thicknesses etc.

In the Algebra window you should be able to see the function f(x) = x2. If you double-click
on this you can modify the function to any other function you like.

6 - Exporting a Picture/ Exporting to the Clipboard
GeoGebra’s drawing pad can be exported as a picture or exported to your computer’s clipboard.
You can then insert it, or paste directly from the clipboard, into any word processing or presen-
tation documents to allow you to create mathematically accurate sketches for tests or notes.

GeoGebra will export the whole graphics window into the clipboard. You will probably have
to make the GeoGebra window smaller so that you get just the parts of your drawing that you
want.

Preparations

\ Open an existing GeoGebra file e.g.
the meaning of the derivative.

\ Hide the algebra window.

Step-by-step Instructions

1. Move the diagram to the upper left corner of the drawing pad

2. Use the zoom tools to get the figure the way you want it

3.
Reduce the size of the GeoGebra window by dragging its lower right corner
with the mouse

4. Use the File menu
Export→ Graphics View to Clipboard or
Export→ Graphics View as Picture (png, eps) . . .

5.
The picture is now stored in the Clipboard (or on your computer) and can be
pasted/inserted into any other document by the methods of whatever applica-
tion you are using.
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Before Reduction After Reduction

7 - Challenge: Creating Instructional Material
Pick a mathematical topic of your own choice that you want to teach to your students. Create a
worksheet to distribute to your students.

Tasks to Complete

\ Open a new file in GeoGebra.

\ Create at least one figure in GeoGe-
bra and export it to the clipboard.

\ Insert it into a word processing doc-
ument.

\ Add explanations, instructions and
problems for your students.
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